配置smart-link主备备份

组网需求

如图一所示,为了保证网络的可靠性,用户侧网络采用双上行方式组网。用户希望能够破除网络环路,实现主备链路冗余备份和快速收敛。

图1 配置Smart Link主备备份示例

配置思路

采用如下的思路配置Smart Link功能:

  1. 创建VLAN,并配置接口允许相应VLAN通过。
  2. 在SwitchA上创建Smart Link备份组,并指定端口角色。
  3. 在SwitchA上使能回切功能,使得故障恢复后,流量切换到相对稳定的原主链路上。
  4. 在SwitchA上使能发送Flush报文功能。
  5. 在SwitchB、SwitchC和SwitchD三台设备对应端口上使能Flush报文接收功能。
  6. 在SwitchA上使能Smart Link组功能。

操作步骤

  1. 配置VLAN信息# 在SwitchA上创建VLAN,并配置接口允许相应VLAN通过。SwitchB、SwitchC和SwitchD的配置与SwitchA类似,详见配置文件。
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10 to 30 
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 10 to 30
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 10 to 30
    [SwitchA-GigabitEthernet0/0/2] quit
    
  2. SwitchA上创建Smart Link备份组,并指定端口角色# 配置SwitchA
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] stp disable
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] stp disable
    [SwitchA-GigabitEthernet0/0/2] quit
    [SwitchA] smart-link group 1
    [SwitchA-smlk-group1] port gigabitethernet 0/0/1 master
    [SwitchA-smlk-group1] port gigabitethernet 0/0/2 slave
    
  3. 使能回切功能并设置回切时间# 配置SwitchA。
    [SwitchA-smlk-group1] restore enable
    [SwitchA-smlk-group1] timer wtr 30
    
  4. 使能发送Flush报文功能# 配置SwitchA,并指定发送Flush报文的密码为SHA加密方式。
    [SwitchA-smlk-group1] flush send control-vlan 10 password sha 123
    
  5. 使能接收Flush报文功能# 配置SwitchB,并指定接收Flush报文的密码为SHA加密方式。
    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] smart-link flush receive control-vlan 10 password sha 123
    [SwitchB-GigabitEthernet0/0/1] stp disable
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface gigabitethernet 0/0/2
    [SwitchB-GigabitEthernet0/0/2] smart-link flush receive control-vlan 10 password sha 123
    [SwitchB-GigabitEthernet0/0/2] stp disable
    [SwitchB-GigabitEthernet0/0/2] quit
    

    # 配置SwitchC,并指定接收Flush报文的密码为SHA加密方式。

    [SwitchC] interface gigabitethernet 0/0/1
    [SwitchC-GigabitEthernet0/0/1] smart-link flush receive control-vlan 10 password sha 123
    [SwitchC-GigabitEthernet0/0/1] stp disable
    [SwitchC-GigabitEthernet0/0/1] quit
    [SwitchC] interface gigabitethernet 0/0/2
    [SwitchC-GigabitEthernet0/0/2] smart-link flush receive control-vlan 10 password sha 123
    [SwitchC-GigabitEthernet0/0/2] stp disable
    [SwitchC-GigabitEthernet0/0/2] quit
    

    # 配置SwitchD,并指定接收Flush报文的密码为SHA加密方式。

    [SwitchD] interface gigabitethernet 0/0/1
    [SwitchD-GigabitEthernet0/0/1] smart-link flush receive control-vlan 10 password sha 123
    [SwitchD-GigabitEthernet0/0/1] stp disable
    [SwitchD-GigabitEthernet0/0/1] quit
    [SwitchD] interface gigabitethernet 0/0/2
    [SwitchD-GigabitEthernet0/0/2] smart-link flush receive control-vlan 10 password sha 123
    [SwitchD-GigabitEthernet0/0/2] stp disable
    [SwitchD-GigabitEthernet0/0/2] quit
    
  6. SwitchA使能Smart Link组功能
    [SwitchA-smlk-group1] smart-link enable
    [SwitchA-smlk-group1] quit
  7. 验证配置结果# 使用display smart-link group命令查看SwitchA上的Smart Link组信息。如果显示如下信息,则表示配置成功。
    • Smart Link组功能已经使能
    • 回切时间为30秒
    • 控制VLAN编号为10
    • 接口GE0/0/1为主接口且处于Active状态,接口GE0/0/2为从接口且处于Inactive。
    [SwitchA] display smart-link group 1
    Smart Link group 1 information :
      Smart Link group was enabled
      Wtr-time is: 30 sec.
      There is no Load-Balance
      There is no protected-vlan reference-instance
      DeviceID: 0018-2000-0083  Control-vlan ID: 10
      Member                  Role    State      Flush Count  Last-Flush-Time
      ----------------------------------------------------------------------
    
      GigabitEthernet0/0/1    Master  Active    1            2009/01/05 10:33:46 UTC+05:00
      GigabitEthernet0/0/2    Slave   Inactive  0            0000/00/00 00:00:00 UTC+05:00
    

    # 使用shutdown命令关闭接口GE0/0/1,可以看到接口GE0/0/1已经处于Inactive状态,接口GE0/0/2为Active状态。

    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] shutdown
    [SwitchA-GigabitEthernet0/0/1] display smart-link group 1
    Smart Link group 1 information :
      Smart Link group was enabled
      Wtr-time is: 30 sec.
      There is no Load-Balance
      There is no protected-vlan reference-instance 
      DeviceID: 0018-2000-0083  Control-vlan ID: 10
      Member                  Role    State      Flush Count  Last-Flush-Time
      ----------------------------------------------------------------------
    
      GigabitEthernet0/0/1    Master  Inactive  1            2009/01/05 10:33:46 UTC+05:00
      GigabitEthernet0/0/2    Slave   Active    1            2009/01/05 10:34:46 UTC+05:00
    

    # 使用undo shutdown命令开启接口GE0/0/1

    [SwitchA-GigabitEthernet0/0/1] undo shutdown

    # 等待30秒后,可以看到接口GE0/0/1处于Active状态,接口GE0/0/2为Inactive状态。

    [SwitchA-GigabitEthernet0/0/1] display smart-link group 1
    Smart Link group 1 information :
      Smart Link group was enabled
      Wtr-time is: 30 sec.
      There is no Load-Balance
      There is no protected-vlan reference-instance 
      DeviceID: 0018-2000-0083  Control-vlan ID: 10
      Member                  Role    State      Flush Count  Last-Flush-Time
      ----------------------------------------------------------------------
    
      GigabitEthernet0/0/1    Master  Active    2            2009/01/05 10:35:46 UTC+05:00
      GigabitEthernet0/0/2    Slave   Inactive  1            2009/01/05 10:34:46 UTC+05:00
    

配置文件

  • SwitchA的配置文件
    #
    sysname SwitchA
    #
    vlan batch 10 to 30
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     stp disable
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     stp disable
    #
    smart-link group 1
     restore enable
     smart-link enable
     port GigabitEthernet0/0/1 master
     port GigabitEthernet0/0/2 slave
     timer wtr 30
     flush send control-vlan 10 password sha %#%#rwIhOw`~g7,xyl>~|:v9Cyw2CH,7l2\dbzA[cH3YA9BdA;1qqSs%WJHM3|hO%#%#
    #
    return
  • SwitchB的配置文件
    #
    sysname SwitchB
    #
    vlan batch 10 to 30
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     stp disable
     smart-link flush receive control-vlan 10 password sha %#%#fR)IGHHT:>]iNbG:Nq#)<^1p#`np!T#/\V&%)iHB_ibX!99]e#E{/L2Sxw!I%#%#
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     stp disable
     smart-link flush receive control-vlan 10 password sha %#%#XbPxG#g5C6$/*d2^GRU>3ODTJF_C(Bht`^*}tT05u]7SIZ5y%9bQ!x~3:v;O%#%#
    #
    return
  • SwitchC的配置文件
    #
    sysname SwitchC
    #
    vlan batch 10 to 30
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     stp disable
     smart-link flush receive control-vlan 10 password sha %#%#IOf[Q`=F=QK"O4-j9A}Y-N7<,F~cn%/NR:G-,L5*[SMN,FlIYAZd88*ObE;T%#%#
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     stp disable
     smart-link flush receive control-vlan 10 password sha %#%#vMK'GvJozEo1Fi:%~jkO<ge&0HgYZVh@ch709e49'r8&M{k6X.NzX)<K_R<P%#%#
    #
    return
  • SwitchD的配置文件
    #
    sysname SwitchD
    #
    vlan batch 10 to 30
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     stp disable
     smart-link flush receive control-vlan 10 password sha %#%#:ssvXl%=T&UGOl$eoPWJaQ'>)@+TbEELAQM=7sh~J1>;>,H<HIEjK$@kW1B1%#%#
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 10 to 30
     stp disable
     smart-link flush receive control-vlan 10 password sha %#%#i~K431w:TERjN]OK0kS+Y*VB=*-BP2+X33UoHVG#{<qPBD:s1.~,2h/s($\&%#%#
    #
    return
配置smart-link主备备份https://www.x8xx.cn/archives/166.htmlXuewei-ZhuXuewei-Zhu
THE END
分享
二维码
打赏
< <上一篇
下一篇>>
文章目录
关闭
目 录