交换机之间直连的2种链路聚合配置方法

前言以太网链路聚合Eth-Trunk简称链路聚合,通过将多个物理接口捆绑为一个逻辑接口,可以在不进行硬件升级的条件下,达到增加链路带宽的目的。
链路聚合技术主要有以下三个优势:

  • 增加带宽链路聚合接口的最大带宽可以达到各成员接口带宽之和。
  • 提高可靠性当某条活动链路出现故障时,流量可以切换到其他可用的成员链路上,从而提高链路聚合接口的可靠性。
  • 负载分担在一个链路聚合组内,可以实现在各成员活动链路上的负载分担。

本期主要介绍链路聚合中交换机之间直连两种实战示例

01 配置手工模式链路聚合(交换机之间直连)1.1  组网需求
如图 1 所示,SwitchA和SwitchB通过以太链路分别都连接VLAN10和VLAN20的网络,且SwitchA和SwitchB之间有较大的数据流量。用户希望SwitchA和SwitchB之间能够提供较大的链路带宽来使相同VLAN间互相通信。同时用户也希望能够提供一定的冗余度,保证数据传输和链路的可靠性。
图 1  配置手工模式链路聚合组网图
1.2  配置思路采用如下的思路配置负载分担链路聚合:

  • 创建Eth-Trunk接口并加入成员接口,实现增加链路带宽。
  • 创建VLAN并将接口加入VLAN。
  • 配置负载分担方式,实现流量在Eth-Trunk各成员接口间的负载分担,增加可靠性。

1.3  操作步骤

【1】在SwitchA和SwitchB上创建Eth-Trunk接口并加入成员接口。

<HUAWEI> system-view
[HUAWEI] sysname SwitchA
[SwitchA] interface eth-trunk 1
[SwitchA-Eth-Trunk1] trunkport gigabitethernet 1/0/1 to 1/0/3
[SwitchA-Eth-Trunk1] quit
<HUAWEI> system-view
[HUAWEI] sysname SwitchB
[SwitchB] interface eth-trunk 1
[SwitchB-Eth-Trunk1] trunkport gigabitethernet 1/0/1 to 1/0/3
[SwitchB-Eth-Trunk1] quit

【2】创建VLAN并将接口加入VLAN。

 

# 创建VLAN10和VLAN20并分别加入接口。SwitchB的配置与SwitchA类似,不再赘述。

[SwitchA] vlan batch 10 20
[SwitchA] interface gigabitethernet 1/0/4
[SwitchA-GigabitEthernet1/0/4] port link-type trunk
[SwitchA-GigabitEthernet1/0/4] port trunk allow-pass vlan 10
[SwitchA-GigabitEthernet1/0/4] quit
[SwitchA] interface gigabitethernet 1/0/5
[SwitchA-GigabitEthernet1/0/5] port link-type trunk
[SwitchA-GigabitEthernet1/0/5] port trunk allow-pass vlan 20
[SwitchA-GigabitEthernet1/0/5] quit

# 配置Eth-Trunk1接口允许VLAN10和VLAN20通过。SwitchB的配置与SwitchA类似,不再赘述。

[SwitchA] interface eth-trunk 1
[SwitchA-Eth-Trunk1] port link-type trunk
[SwitchA-Eth-Trunk1] port trunk allow-pass vlan 10 20
[SwitchA-Eth-Trunk1] quit

【3】配置Eth-Trunk1的负载分担方式。SwitchB的配置与SwitchA类似,不再赘述。

[SwitchA] interface eth-trunk 1
[SwitchA-Eth-Trunk1] load-balance src-dst-mac
[SwitchA-Eth-Trunk1] quit

【4】验证配置结果

在任意视图下执行display eth-trunk 1命令,检查Eth-Trunk是否创建成功,及成员接口是否正确加入。

[SwitchA] display eth-trunk 1
Eth-Trunk1's state information is: 
WorkingMode: NORMAL           Hash arithmetic: According to SA-XOR-DA
Least Active-linknumber: 1     Max Bandwidth-affected-linknumber: 8
Operate status: up             Number Of Up Port In Trunk: 3 
--------------------------------------------------------------------------------
PortName                           Status       Weight
GigabitEthernet1/0/1               Up           1
GigabitEthernet1/0/2               Up           1
GigabitEthernet1/0/3               Up           1

从以上信息看出Eth-Trunk 1中包含3个成员接口GigabitEthernet1/0/1、GigabitEthernet1/0/2和GigabitEthernet1/0/3,成员接口的状态都为Up。Eth-Trunk 1的“Operate status”为Up

1.4  配置文件

#SwitchA的配置文件

#
sysname SwitchA
#
vlan batch 10 20
# 
interface Eth-Trunk1
 port link-type trunk 
 port trunk allow-pass vlan 10 20
 load-balance src-dst-mac 
# 
interface GigabitEthernet1/0/1 
 eth-trunk 1
# 
interface GigabitEthernet1/0/2 
 eth-trunk 1
# 
interface GigabitEthernet1/0/3 
 eth-trunk 1
#
interface GigabitEthernet1/0/4 
 port link-type trunk 
 port trunk allow-pass vlan 10
#
interface GigabitEthernet1/0/5 
 port link-type trunk 
 port trunk allow-pass vlan 20
#
return

#SwitchB的配置文件

#
sysname SwitchB
#
vlan batch 10 20
# 
interface Eth-Trunk1
 port link-type trunk 
 port trunk allow-pass vlan 10 20
 load-balance src-dst-mac 
# 
interface GigabitEthernet1/0/1 
 eth-trunk 1
# 
interface GigabitEthernet1/0/2 
 eth-trunk 1
# 
interface GigabitEthernet1/0/3 
 eth-trunk 1
#
interface GigabitEthernet1/0/4 
 port link-type trunk 
 port trunk allow-pass vlan 10
#
interface GigabitEthernet1/0/5 
 port link-type trunk 
 port trunk allow-pass vlan 20
#
return
02配置LACP模式的链路聚合示例(交换机之间直连)2.1  组网需求
如图 2 所示,SwitchA和SwitchB通过以太链路分别都连接VLAN10和VLAN20的网络,且SwitchA和SwitchB之间有较大的数据流量。用户希望SwitchA和SwitchB之间能够提供较大的链路带宽来使相同VLAN间互相通信。在两台Switch设备上配置LACP模式链路聚合组,提高两设备之间的带宽与可靠性,具体要求如下:

 

 

 

 

 

  • 两条活动链路具有负载分担的能力。
  • 两设备间的链路具有1条冗余备份链路,当活动链路出现故障时,备份链路替代故障链路,保持数据传输的可靠性。
  • 同VLAN间可以相互通信。
图 2  配置LACP模式链路聚合组网图
2.2  配置思路采用如下的思路配置LACP模式链路聚合:

  • 创建Eth-Trunk,配置Eth-Trunk为LACP模式,实现链路聚合功能。
  • 将成员接口加入Eth-Trunk。
  • 配置系统优先级,确定主动端,按照主动端设备的接口选择活动接口。
  • 配置活动接口上限阈值,实现保证带宽的情况下提高网络的可靠性。
  • 配置接口优先级,确定活动链路接口,优先级高的接口将被选作活动接口。
  • 创建VLAN并将接口加入VLAN。

2.3  操作步骤

【1】在SwitchA上创建Eth-Trunk1并配置为LACP模式。SwitchB的配置与SwitchA类似,不再赘述

<HUAWEI> system-view
[HUAWEI] sysname SwitchA
[SwitchA] interface eth-trunk 1
[SwitchA-Eth-Trunk1] mode lacp
[SwitchA-Eth-Trunk1] quit

【2】配置SwitchA上的成员接口加入Eth-Trunk。SwitchB的配置与SwitchA类似,不再赘述

[SwitchA] interface gigabitethernet 1/0/1
[SwitchA-GigabitEthernet1/0/1] eth-trunk 1
[SwitchA-GigabitEthernet1/0/1] quit
[SwitchA] interface gigabitethernet 1/0/2
[SwitchA-GigabitEthernet1/0/2] eth-trunk 1
[SwitchA-GigabitEthernet1/0/2] quit
[SwitchA] interface gigabitethernet 1/0/3
[SwitchA-GigabitEthernet1/0/3] eth-trunk 1
[SwitchA-GigabitEthernet1/0/3] quit

【3】在SwitchA上配置系统优先级为100,使其成为LACP主动端

[SwitchA] lacp priority 100

【4】在SwitchA上配置活动接口上限阈值为2

[SwitchA] interface eth-trunk 1
[SwitchA-Eth-Trunk1] max active-linknumber 2
[SwitchA-Eth-Trunk1] quit

【5】在SwitchA上配置接口优先级确定活动链路

[SwitchA] interface gigabitethernet 1/0/1
[SwitchA-GigabitEthernet1/0/1] lacp priority 100
[SwitchA-GigabitEthernet1/0/1] quit
[SwitchA] interface gigabitethernet 1/0/2
[SwitchA-GigabitEthernet1/0/2] lacp priority 100
[SwitchA-GigabitEthernet1/0/2] quit

【6】创建VLAN并将接口加入VLAN。

# 创建VLAN10和VLAN20并分别加入接口。SwitchB的配置与SwitchA类似,不再赘述。

[SwitchA] vlan batch 10 20
[SwitchA] interface gigabitethernet 1/0/4
[SwitchA-GigabitEthernet1/0/4] port link-type trunk
[SwitchA-GigabitEthernet1/0/4] port trunk allow-pass vlan 10
[SwitchA-GigabitEthernet1/0/4] quit
[SwitchA] interface gigabitethernet 1/0/5
[SwitchA-GigabitEthernet1/0/5] port link-type trunk
[SwitchA-GigabitEthernet1/0/5] port trunk allow-pass vlan 20
[SwitchA-GigabitEthernet1/0/5] quit

# 配置Eth-Trunk1接口允许VLAN10和VLAN20通过。SwitchB的配置与SwitchA类似,不再赘述。

[SwitchA] interface eth-trunk 1
[SwitchA-Eth-Trunk1] port link-type trunk
[SwitchA-Eth-Trunk1] port trunk allow-pass vlan 10 20
[SwitchA-Eth-Trunk1] quit

【7】验证配置结果

# 查看各Switch设备的Eth-Trunk信息,查看链路是否协商成功。

[SwitchA] display eth-trunk 1
Eth-Trunk1's state information is:
Local:                                                                          
LAG ID: 1                       WorkingMode: LACP                             
Preempt Delay: Disabled         Hash arithmetic: According to SIP-XOR-DIP       
System Priority: 100            System ID: 00e0-fca8-0417
Least Active-linknumber: 1      Max Active-linknumber: 2                        
Operate status: up              Number Of Up Port In Trunk: 2
--------------------------------------------------------------------------------
ActorPortName                    Status     PortType PortPri   PortNo PortKey   PortState  Weight
GigabitEthernet1/0/1             Selected  1GE       100      6145    2865      11111100     1
GigabitEthernet1/0/2             Selected  1GE       100      6146    2865      11111100     1
GigabitEthernet1/0/3             Unselect  1GE       32768    6147    2865      11100000     1

Partner:
--------------------------------------------------------------------------------
ActorPortName                     SysPri    SystemID    PortPri PortNo PortKey   PortState
GigabitEthernet1/0/1              32768  00e0-fca6-7f85  32768     6145   2609      11111100
GigabitEthernet1/0/2              32768  00e0-fca6-7f85  32768     6146   2609      11111100
GigabitEthernet1/0/3              32768  00e0-fca6-7f85  32768     6147   2609      11110000
[SwitchB] display eth-trunk 1
Eth-Trunk1's state information is:
Local:
LAG ID: 1                      WorkingMode: LACP
Preempt Delay: Disabled        Hash arithmetic: According to SIP-XOR-DIP
System Priority: 32768         System ID: 00e0-fca6-7f85
Least Active-linknumber: 1     Max Active-linknumber: 8
Operate status: up             Number Of Up Port In Trunk: 2
--------------------------------------------------------------------------------
ActorPortName                   Status     PortType    PortPri   PortNo  PortKey   PortState  Weight
GigabitEthernet1/0/1            Selected  1GE        32768      6145    2609      11111100     1
GigabitEthernet1/0/2            Selected  1GE        32768      6146    2609      11111100     1
GigabitEthernet1/0/3            Unselect  1GE        32768      6147    2609      11100000     1

Partner:
--------------------------------------------------------------------------------
ActorPortName                     SysPri    SystemID     PortPri  PortNo  PortKey   PortState
GigabitEthernet1/0/1              100    00e0-fca8-0417  100      6145     2865      11111100
GigabitEthernet1/0/2              100    00e0-fca8-0417  100      6146     2865      11111100
GigabitEthernet1/0/3              100    00e0-fca8-0417  32768    6147     2865      11110000

通过以上显示信息可以看到,SwitchA的系统优先级为100,高于SwitchB的系统优先级。Eth-Trunk的成员接口中GigabitEthernet1/0/1、GigabitEthernet1/0/2成为活动接口,处于“Selected”状态,接口GigabitEthernet1/0/3处于“Unselect”状态,同时实现M条链路的负载分担和N条链路的冗余备份功能。

2.4  配置文件

SwitchA的配置文件

#
sysname SwitchA
#
vlan batch 10 20
#
lacp priority 100
#
interface Eth-Trunk1
 port link-type trunk
 port trunk allow-pass vlan 10 20
 mode lacp
 max active-linknumber 2
#
interface GigabitEthernet1/0/1
 eth-trunk 1
 lacp priority 100
#
interface GigabitEthernet1/0/2
 eth-trunk 1
 lacp priority 100
#
interface GigabitEthernet1/0/3
 eth-trunk 1
#
interface GigabitEthernet1/0/4
 port link-type trunk 
 port trunk allow-pass vlan 10
#
interface GigabitEthernet1/0/5
 port link-type trunk 
 port trunk allow-pass vlan 20
#
return

SwitchB的配置文件

#
sysname SwitchB
#
vlan batch 10 20
#
interface Eth-Trunk1
 port link-type trunk
 port trunk allow-pass vlan 10 20
 mode lacp
#
interface GigabitEthernet1/0/1
 eth-trunk 1
#
interface GigabitEthernet1/0/2
 eth-trunk 1
#
interface GigabitEthernet1/0/3
 eth-trunk 1
#
interface GigabitEthernet1/0/4
 port link-type trunk 
 port trunk allow-pass vlan 10
#
interface GigabitEthernet1/0/5
 port link-type trunk 
 port trunk allow-pass vlan 20
#
return
THE END